Renegade Public Forums
C&C: Renegade -- Dead since 2012!™
Home » Renegade Discussions » Tiberian Technologies Forum » Hit Cancel on auto update
Hit Cancel on auto update [message #485691] Wed, 05 February 2014 16:36 Go to next message
Blazea58  is currently offline Blazea58  
Messages: 408
Registered: May 2003
Commander

From: *cg.shawcable.net
I don't know what to do now, today i clicked the game to play and it was taking a while (didn't realize it was updating) so I clicked the game again and it started downloading two patches at once. I hit cancel on the second one, and now it won't allow me to start the game anymore. I tried installing the latest patch from here and as its installing it, there's a few more missing Dll's. TTCore.dll,UAC Launcher.exe and now it tells me I'm missing Zlib1.dll when i try to launch the game. Other then reinstalling renegade from scratch, any other solutions?


http://i175.photobucket.com/albums/w125/Blaze558/ECW_WebBanner1.jpg
Re: Hit Cancel on auto update [message #485692] Wed, 05 February 2014 17:09 Go to previous messageGo to next message
StealthEye  is currently offline StealthEye  
Messages: 2518
Registered: May 2006
Location: The Netherlands
General (2 Stars)

From: *xs4all.nl
Did you get the RC2 client installer from http://tiberiantechnologies.org/downloads ? It should fix any corrupt installation. If that does not work, it is a bug. In that case, please zip up your entire renegade folder and send it to me. You may leave out the .mix and .dat files in the data folder to reduce the size. After you have done that you may try to delete the .dll and .exe files in your Renegade folder and run the installer again, that might work around the issue.


BlackIntel admin/founder/coder
Please visit http://www.blackintel.org/
Re: Hit Cancel on auto update [message #485785] Fri, 07 February 2014 10:13 Go to previous message
StealthEye  is currently offline StealthEye  
Messages: 2518
Registered: May 2006
Location: The Netherlands
General (2 Stars)

From: *xs4all.nl
Note that there is another issue that sometimes causes the install to fail (see quote below). To fix your issue completely, download the RC2 installer from http://tiberiantechnologies.org/downloads and then install the following two packages:

http://www.microsoft.com/en-gb/download/details.aspx?id=35
http://www.microsoft.com/en-gb/download/details.aspx?id=30679

Quote:

I have identified the issue and it will be fixed as soon as possible, hopefully in a few hours. I'll post in the release topic when it is fixed. Until then, you can fix the issue by installing the following packages manually if you have not already done so:

http://www.microsoft.com/en-gb/download/details.aspx?id=35
http://www.microsoft.com/en-gb/download/details.aspx?id=30679

The RC2 installer erroneously attempts to install both at the same time, whereas only one simultaneous installation is allowed. That causes one of both installations to fail.

Thanks to everyone who helped me debug this issue by reporting on IRC/PM. Smile

(Crossposting this to all related topics.)


BlackIntel admin/founder/coder
Please visit http://www.blackintel.org/
Previous Topic:New 4.0 bug not letting players join
Next Topic:Update problem (4.1 I guess?)
Goto Forum:
  


Current Time: Sat Nov 17 16:54:07 MST 2018
.:: Contact :: Home ::.

Powered by: FUDforum 2.7.7RC2.
Copyright ©2001-2007 FUD Forum Bulletin Board Software