Renegade Public Forums
C&C: Renegade -- Dead since 2012!™
Home » Renegade Discussions » Tiberian Technologies Forum » BRenBot 1.53.10
BRenBot 1.53.10 [message #461391] Sun, 08 January 2012 06:43 Go to next message
danpaul88  is currently offline danpaul88  
Messages: 5794
Registered: June 2004
Location: England
General (5 Stars)
From: *range86-174.btcentralplus.com
** SSGM 4.0 support requires server side scripts.dll compiled from TT revision 4076 or higher **

Changes since 1.53.9
- Fix missing MD5 library which prevented auth passwords being verified
- Changed default presets.cfg entry for mp_GDI_War_Factory to "Weapons Factory" from "War Factory"
- Removed some redundant duplicated RenRem functions


Existing plugins might or might not work with this, let me know if you have any problems with them.

  • Attachment: br_1-53-10.7z
    (Size: 5.34MB, Downloaded 206 time(s))

[Updated on: Sun, 08 January 2012 09:26]


http://steamsignature.com/card/1/76561197975867233.png
Re: BRenBot 1.53.10 [message #461393] Sun, 08 January 2012 07:44 Go to previous messageGo to next message
ExEric3  is currently offline ExEric3  
Messages: 730
Registered: February 2005
Location: Slovakia
Colonel

From: *orange.sk
Download? In Love
Re: BRenBot 1.53.10 [message #461397] Sun, 08 January 2012 09:13 Go to previous messageGo to next message
Omar007  is currently offline Omar007  
Messages: 1711
Registered: December 2007
Location: Amsterdam
General (1 Star)

From: *xs4all.nl
ExEric3 wrote on Sun, 08 January 2012 15:44

Download? In Love

Would be handy indeed Thumbs Up


http://tiberiumredux.omarpakker.nl/Old Unused Parts/Plaatjes/PromoteBanner_Hades_small.jpg
Re: BRenBot 1.53.10 [message #461398] Sun, 08 January 2012 09:25 Go to previous messageGo to next message
danpaul88  is currently offline danpaul88  
Messages: 5794
Registered: June 2004
Location: England
General (5 Stars)
From: *range86-174.btcentralplus.com
Psh, you fussy people, just use your imaginations Big Grin



Apparently it works better if you click 'Upload File' instead of just submitting the post after browsing to the file location...

[Updated on: Sun, 08 January 2012 09:28]


http://steamsignature.com/card/1/76561197975867233.png
Re: BRenBot 1.53.10 [message #461485] Mon, 09 January 2012 17:51 Go to previous messageGo to next message
Creed3020  is currently offline Creed3020  
Messages: 1438
Registered: February 2003
Location: Toronto, Canada
General (1 Star)
From: *cable.teksavvy.com
danpaul88 wrote on Sun, 08 January 2012 08:43

** SSGM 4.0 support requires server side scripts.dll compiled from TT revision 4076 or higher **

Changes since 1.53.9
- Fix missing MD5 library which prevented auth passwords being verified
- Changed default presets.cfg entry for mp_GDI_War_Factory to "Weapons Factory" from "War Factory"
- Removed some redundant duplicated RenRem functions


Existing plugins might or might not work with this, let me know if you have any problems with them.



So that is why I could never get the !auth to work on my test server. Thanks for the fix DP!
Re: BRenBot 1.53.10 [message #461510] Tue, 10 January 2012 11:06 Go to previous messageGo to next message
Caveman  is currently offline Caveman  
Messages: 2476
Registered: July 2005
Location: Wales, UK
General (2 Stars)

From: *bb.sky.com
I just installed this for the clanwar servers and its not displaying any messages ingame?

When I talk ingame, nothing appears on IRC, when I use !gi it display the correct information but if I type !msg test nothing appears. If I use renrem or the console directly it display msg test and BR reads it.

I thought maybe it might be a plugin issue but ive disabled them all..

It looks like this thread as well.

http://www.renegadeforums.com/index.php?t=msg&th=38924&start=0&rid=2 5967


CarrierII wrote

BLUEHTHEN YOU AR NOT JUST A BIG CHEATAS AND YOU THE BIG HEAD JUST YOU USE FLY H4X FUCK YOU BIG CHEATAS YOUR CHEATZ IS BAD YOU WANT I WRAUGHT THIS YOUR CHEATZ IS BAD HEY IS 1 YEAR YOUR PROMESS A FLY HAX IN MULTIPLAYER AND IS DONT JUST TROOPRM02 I TELL IT ALL WHO REPLYER IN THIS FORUM YOU CHEATZ

Please don't make me type something like that again, not using puntuation is annoying.


http://r9.fodey.com/2158/bc450f3ca15045e9bdd7651fa49f3a0a.0.gif
Re: BRenBot 1.53.10 [message #461515] Tue, 10 January 2012 12:52 Go to previous messageGo to next message
Sean  is currently offline Sean  
Messages: 822
Registered: February 2009
Colonel

From: *know.cable.virginmedia.com
Well done sir, I'm glad to see the exploits have been fixed in previous versions. Thumbs Up


Head admin at TmX (The Matrix Sniper server)

irc.thematrixserver.com
The Matrix Sniper: 188.138.84.134:4576
Re: BRenBot 1.53.10 [message #461532] Tue, 10 January 2012 18:32 Go to previous messageGo to next message
iRANian  is currently offline iRANian  
Messages: 4294
Registered: April 2011
General (4 Stars)
From: *cm-8.dynamic.ziggo.nl
Using !KB crashes BRenBot for Jelly, !kick allows players to immediately rejoin and the PAMSG you get when kicked doesn't tell you who kicked you. Also sending out multiple PASMGs prevents players from accidentally clicking one of them off would be nice.

[Updated on: Tue, 10 January 2012 18:33]


Long time and well respected Renegade community member, programmer, modder and tester.

Scripts 4.0 private beta tester since May 2011.

My Renegade server plugins releases
Re: BRenBot 1.53.10 [message #461542] Wed, 11 January 2012 01:24 Go to previous messageGo to next message
danpaul88  is currently offline danpaul88  
Messages: 5794
Registered: June 2004
Location: England
General (5 Stars)
From: *range86-174.btcentralplus.com
Under 4.0 the pamsg is sent by scripts.DLL as part of the new kicking and banning ssgm code.

When it crashes what does it say on the console? (run from command prompt so the window doesn't close)

[Updated on: Wed, 11 January 2012 01:25]


http://steamsignature.com/card/1/76561197975867233.png
Re: BRenBot 1.53.10 [message #461548] Wed, 11 January 2012 05:14 Go to previous messageGo to next message
iRANian  is currently offline iRANian  
Messages: 4294
Registered: April 2011
General (4 Stars)
From: *cm-8.dynamic.ziggo.nl
I know that bansystem.dll does the PAMSG, I was wondering if you could add multiple ones, as soon as a player presses spacebar (this might accidentally happen if they're about to jump), the messages window disappeared and it will look like they simply disconnected from the server.


Long time and well respected Renegade community member, programmer, modder and tester.

Scripts 4.0 private beta tester since May 2011.

My Renegade server plugins releases
Re: BRenBot 1.53.10 [message #461584] Wed, 11 January 2012 17:01 Go to previous messageGo to next message
StealthEye  is currently offline StealthEye  
Messages: 2518
Registered: May 2006
Location: The Netherlands
General (2 Stars)

From: *xs4all.nl
They'll find out when they try to rejoin then. Wink


BlackIntel admin/founder/coder
Please visit http://www.blackintel.org/
Re: BRenBot 1.53.10 [message #461646] Fri, 13 January 2012 04:24 Go to previous messageGo to next message
Caveman  is currently offline Caveman  
Messages: 2476
Registered: July 2005
Location: Wales, UK
General (2 Stars)

From: *bb.sky.com
Caveman wrote on Tue, 10 January 2012 18:06

I just installed this for the clanwar servers and its not displaying any messages ingame?

When I talk ingame, nothing appears on IRC, when I use !gi it display the correct information but if I type !msg test nothing appears. If I use renrem or the console directly it display msg test and BR reads it.

I thought maybe it might be a plugin issue but ive disabled them all..

It looks like this thread as well.

http://www.renegadeforums.com/index.php?t=msg&th=38924&start=0&rid=2 5967


Bump this?

Brenbot connects to my server it reports when people die but it doesn't do anything else.. I cant use !fds, !gameover things like that but !gi and !pl work fine.. !msg also doesn't work. Ive tried this with SSGM plugins and without.


CarrierII wrote

BLUEHTHEN YOU AR NOT JUST A BIG CHEATAS AND YOU THE BIG HEAD JUST YOU USE FLY H4X FUCK YOU BIG CHEATAS YOUR CHEATZ IS BAD YOU WANT I WRAUGHT THIS YOUR CHEATZ IS BAD HEY IS 1 YEAR YOUR PROMESS A FLY HAX IN MULTIPLAYER AND IS DONT JUST TROOPRM02 I TELL IT ALL WHO REPLYER IN THIS FORUM YOU CHEATZ

Please don't make me type something like that again, not using puntuation is annoying.


http://r9.fodey.com/2158/bc450f3ca15045e9bdd7651fa49f3a0a.0.gif
Re: BRenBot 1.53.10 [message #461649] Fri, 13 January 2012 05:45 Go to previous messageGo to next message
EvilWhiteDragon  is currently offline EvilWhiteDragon  
Messages: 3751
Registered: October 2005
Location: The Netherlands
General (3 Stars)

From: *cm-7-5a.dynamic.ziggo.nl
Sounds like renrem not being setup correctly afaik...


http://www.blackintel.org/usr/evilwhitedragon/pointfix.gif
BlackIntel admin/founder/PR dude (not a coder)
Please visit http://www.blackintel.org/

V, V for Vendetta

People should not be afraid of their governments.
Governments should be afraid of their people.
Re: BRenBot 1.53.10 [message #461650] Fri, 13 January 2012 05:48 Go to previous messageGo to next message
Caveman  is currently offline Caveman  
Messages: 2476
Registered: July 2005
Location: Wales, UK
General (2 Stars)

From: *bb.sky.com
there is no renrem with this br, it uses the tcp port which is working.


CarrierII wrote

BLUEHTHEN YOU AR NOT JUST A BIG CHEATAS AND YOU THE BIG HEAD JUST YOU USE FLY H4X FUCK YOU BIG CHEATAS YOUR CHEATZ IS BAD YOU WANT I WRAUGHT THIS YOUR CHEATZ IS BAD HEY IS 1 YEAR YOUR PROMESS A FLY HAX IN MULTIPLAYER AND IS DONT JUST TROOPRM02 I TELL IT ALL WHO REPLYER IN THIS FORUM YOU CHEATZ

Please don't make me type something like that again, not using puntuation is annoying.


http://r9.fodey.com/2158/bc450f3ca15045e9bdd7651fa49f3a0a.0.gif
Re: BRenBot 1.53.10 [message #461651] Fri, 13 January 2012 06:47 Go to previous messageGo to next message
danpaul88  is currently offline danpaul88  
Messages: 5794
Registered: June 2004
Location: England
General (5 Stars)
From: 195.12.16*
Caveman wrote on Fri, 13 January 2012 12:48

there is no renrem with this br, it uses the tcp port which is working.


Actually, BRenBot only *reads* from the TCP port. All the commands are still sent via the tried and tested RenRem port. At the time I implemented it I didn't have a definitive answer as to whether the TCP port would be a two way mechanism or just an output for the logfiles, hence I didn't go to the trouble of replacing RenRem with the TCP commands mechanism.

Check your BRenBot console, if it detects problems with your RenRem configuration (as read from server.ini or svrccgmg_gnhb.ini or whatever the hell its called, can't remember which off the top of my head) it will print a warning to the console on bootup.

Something along the lines of 'Warning: RemoteAdmin is not enabled in server.ini' would be a big clue Razz



EDIT: Also, RTFM Razz

Quote:

Problem: The bot seems to work, but no messages showup ingame, and some commands
do not work

Resolution: Usually this is caused by incorrect remote admin settings. Ensure that
AllowRemoteAdmin in server.ini is set to true and that the RemoteAdminPassword is
set to an 8 character string. See the setup section for the exact names of these
settings. This can also occur when two or more FDS installations on the machine
are configured with the same RemoteAdminPort setting.



And

Quote:

Added support for SSGM 4.0 TCP logging of SSGMLog, Gamelog and Renlog


Note it specifies support for logging (ie: output), not support for sending commands via TCP Wink

[Updated on: Fri, 13 January 2012 06:58]


http://steamsignature.com/card/1/76561197975867233.png
Re: BRenBot 1.53.10 [message #461667] Fri, 13 January 2012 10:49 Go to previous messageGo to next message
Caveman  is currently offline Caveman  
Messages: 2476
Registered: July 2005
Location: Wales, UK
General (2 Stars)

From: *bb.sky.com
danpaul88 wrote on Fri, 13 January 2012 13:47

Caveman wrote on Fri, 13 January 2012 12:48

there is no renrem with this br, it uses the tcp port which is working.


Actually, BRenBot only *reads* from the TCP port. All the commands are still sent via the tried and tested RenRem port. At the time I implemented it I didn't have a definitive answer as to whether the TCP port would be a two way mechanism or just an output for the logfiles, hence I didn't go to the trouble of replacing RenRem with the TCP commands mechanism.

Check your BRenBot console, if it detects problems with your RenRem configuration (as read from server.ini or svrccgmg_gnhb.ini or whatever the hell its called, can't remember which off the top of my head) it will print a warning to the console on bootup.

Something along the lines of 'Warning: RemoteAdmin is not enabled in server.ini' would be a big clue Razz



EDIT: Also, RTFM Razz

Quote:

Problem: The bot seems to work, but no messages showup ingame, and some commands
do not work

Resolution: Usually this is caused by incorrect remote admin settings. Ensure that
AllowRemoteAdmin in server.ini is set to true and that the RemoteAdminPassword is
set to an 8 character string. See the setup section for the exact names of these
settings. This can also occur when two or more FDS installations on the machine
are configured with the same RemoteAdminPort setting.



And

Quote:

Added support for SSGM 4.0 TCP logging of SSGMLog, Gamelog and Renlog


Note it specifies support for logging (ie: output), not support for sending commands via TCP Wink

Everything was sweet until I upgraded the bot to build .10... When I had build 9 everything worked as it should. All I did was replace the .exe

when I use !msg or whatever the BR console says its issued the command but nothing gets posted.

I have 3 servers up all using different TCP ports, for example server 1 is using tcp 7500, server 2 is using tcp 7501 and server 3 using 7502

According to BR all the commands im sending it are being executed but they dont get sent to the server.


CarrierII wrote

BLUEHTHEN YOU AR NOT JUST A BIG CHEATAS AND YOU THE BIG HEAD JUST YOU USE FLY H4X FUCK YOU BIG CHEATAS YOUR CHEATZ IS BAD YOU WANT I WRAUGHT THIS YOUR CHEATZ IS BAD HEY IS 1 YEAR YOUR PROMESS A FLY HAX IN MULTIPLAYER AND IS DONT JUST TROOPRM02 I TELL IT ALL WHO REPLYER IN THIS FORUM YOU CHEATZ

Please don't make me type something like that again, not using puntuation is annoying.


http://r9.fodey.com/2158/bc450f3ca15045e9bdd7651fa49f3a0a.0.gif
Re: BRenBot 1.53.10 [message #461668] Fri, 13 January 2012 10:58 Go to previous messageGo to next message
danpaul88  is currently offline danpaul88  
Messages: 5794
Registered: June 2004
Location: England
General (5 Stars)
From: *range86-174.btcentralplus.com
Caveman wrote on Fri, 13 January 2012 17:49


Everything was sweet until I upgraded the bot to build .10... When I had build 9 everything worked as it should. All I did was replace the .exe

when I use !msg or whatever the BR console says its issued the command but nothing gets posted.

I have 3 servers up all using different TCP ports, for example server 1 is using tcp 7500, server 2 is using tcp 7501 and server 3 using 7502

According to BR all the commands im sending it are being executed but they dont get sent to the server.



TCP port is irrelevant for *sending* commands since the RenRem port is used for those.

[Updated on: Fri, 13 January 2012 10:58]


http://steamsignature.com/card/1/76561197975867233.png
Re: BRenBot 1.53.10 [message #461669] Fri, 13 January 2012 11:02 Go to previous messageGo to next message
Caveman  is currently offline Caveman  
Messages: 2476
Registered: July 2005
Location: Wales, UK
General (2 Stars)

From: *bb.sky.com
Right - But its not sending via RenRem... The RR settings are fine, if I connect remotely with renrem I can do whatever but the bot cant.

The port is unused, the password is 8 digits long 1 of which contains a number.


CarrierII wrote

BLUEHTHEN YOU AR NOT JUST A BIG CHEATAS AND YOU THE BIG HEAD JUST YOU USE FLY H4X FUCK YOU BIG CHEATAS YOUR CHEATZ IS BAD YOU WANT I WRAUGHT THIS YOUR CHEATZ IS BAD HEY IS 1 YEAR YOUR PROMESS A FLY HAX IN MULTIPLAYER AND IS DONT JUST TROOPRM02 I TELL IT ALL WHO REPLYER IN THIS FORUM YOU CHEATZ

Please don't make me type something like that again, not using puntuation is annoying.


http://r9.fodey.com/2158/bc450f3ca15045e9bdd7651fa49f3a0a.0.gif
Re: BRenBot 1.53.10 [message #461670] Fri, 13 January 2012 11:13 Go to previous messageGo to next message
danpaul88  is currently offline danpaul88  
Messages: 5794
Registered: June 2004
Location: England
General (5 Stars)
From: *range86-174.btcentralplus.com
The code for sending RenRem commands hasn't been modified since before June 2009 so I don't know what else to suggest. As long as each server has a unique RenRem UDP port in its config, the port is not used by any other applications and not firewalled, an 8 character long password and AllowRemoteAdmin is true it should work fine.

[Updated on: Fri, 13 January 2012 11:14]


http://steamsignature.com/card/1/76561197975867233.png
Re: BRenBot 1.53.10 [message #461671] Fri, 13 January 2012 11:21 Go to previous messageGo to next message
Caveman  is currently offline Caveman  
Messages: 2476
Registered: July 2005
Location: Wales, UK
General (2 Stars)

From: *bb.sky.com
All that ^ is true but its not working.. Could they be a problem with it reading the server.ini?


CarrierII wrote

BLUEHTHEN YOU AR NOT JUST A BIG CHEATAS AND YOU THE BIG HEAD JUST YOU USE FLY H4X FUCK YOU BIG CHEATAS YOUR CHEATZ IS BAD YOU WANT I WRAUGHT THIS YOUR CHEATZ IS BAD HEY IS 1 YEAR YOUR PROMESS A FLY HAX IN MULTIPLAYER AND IS DONT JUST TROOPRM02 I TELL IT ALL WHO REPLYER IN THIS FORUM YOU CHEATZ

Please don't make me type something like that again, not using puntuation is annoying.


http://r9.fodey.com/2158/bc450f3ca15045e9bdd7651fa49f3a0a.0.gif
Re: BRenBot 1.53.10 [message #461678] Fri, 13 January 2012 13:05 Go to previous messageGo to next message
danpaul88  is currently offline danpaul88  
Messages: 5794
Registered: June 2004
Location: England
General (5 Stars)
From: *range86-174.btcentralplus.com
Check the console when it boots up for any of the following messages. If none are shown then it read the values from server.ini OK.

if ( lc($1) ne 'true' && $1 ne '1' )
				{ modules::console_output ( '[Config] WARNING: AllowRemoteAdmin option in server.ini is not set to true. BRenBot will not be able to communicate properly with the server!' ); }


if ( length( $1 ) != 8 )
				{ modules::console_output ( '[Config] WARNING: RemoteAdminPassword must be 8 characters long! BRenBot will not be able to communicate properly with the server!' ); }


# Check remote admin port and password were OK
	if ( !$config_renrem_port or !$config_renrem_password )
	{
		modules::console_output ( "[Config] ERROR: Unable to load RemoteAdminPort and/or RemoteAdminPassword from server.ini.\n\nUnable to continue loading." );
		sleep ( 10 );
		exit;
	}


http://steamsignature.com/card/1/76561197975867233.png
Re: BRenBot 1.53.10 [message #461681] Fri, 13 January 2012 13:49 Go to previous messageGo to next message
EvilWhiteDragon  is currently offline EvilWhiteDragon  
Messages: 3751
Registered: October 2005
Location: The Netherlands
General (3 Stars)

From: *cm-7-5a.dynamic.ziggo.nl
Another possible cause is starting the FDS'es and/or bots at the same time. We have seen that issue at BlackIntel, causing commands to go to the wrong server. We still don't exactly understand how the hell that's possible, but it could happen. Wierdest bit was that the renrem ports where 10 ports away from each other normally. So say 5004 would be one renrem port, the other would be 5014 and the one after that 5024, yet sometimes commands got send to the wrong server.


http://www.blackintel.org/usr/evilwhitedragon/pointfix.gif
BlackIntel admin/founder/PR dude (not a coder)
Please visit http://www.blackintel.org/

V, V for Vendetta

People should not be afraid of their governments.
Governments should be afraid of their people.
Re: BRenBot 1.53.10 [message #461682] Fri, 13 January 2012 14:48 Go to previous messageGo to next message
Spoony  is currently offline Spoony  
Messages: 3915
Registered: January 2006
General (3 Stars)
Tactics & Strategies Moderator
From: *dynamic.dsl.as9105.com
i'm not sure what caveman did, but chat messages show up in the CW servers now. commands like !msg, !gameover etc still do not.


Unleash the Renerage™

Renedrama [ren-i-drah-muh]
- noun
1. the inevitable criticism one receives after doing something awful
Re: BRenBot 1.53.10 [message #461685] Fri, 13 January 2012 16:49 Go to previous messageGo to next message
Caveman  is currently offline Caveman  
Messages: 2476
Registered: July 2005
Location: Wales, UK
General (2 Stars)

From: *bb.sky.com
I did nothing, ive been at work.


CarrierII wrote

BLUEHTHEN YOU AR NOT JUST A BIG CHEATAS AND YOU THE BIG HEAD JUST YOU USE FLY H4X FUCK YOU BIG CHEATAS YOUR CHEATZ IS BAD YOU WANT I WRAUGHT THIS YOUR CHEATZ IS BAD HEY IS 1 YEAR YOUR PROMESS A FLY HAX IN MULTIPLAYER AND IS DONT JUST TROOPRM02 I TELL IT ALL WHO REPLYER IN THIS FORUM YOU CHEATZ

Please don't make me type something like that again, not using puntuation is annoying.


http://r9.fodey.com/2158/bc450f3ca15045e9bdd7651fa49f3a0a.0.gif
Re: BRenBot 1.53.10 [message #461691] Fri, 13 January 2012 17:30 Go to previous messageGo to previous message
StealthEye  is currently offline StealthEye  
Messages: 2518
Registered: May 2006
Location: The Netherlands
General (2 Stars)

From: *xs4all.nl
EvilWhiteDragon wrote on Fri, 13 January 2012 21:49

Another possible cause is starting the FDS'es and/or bots at the same time. We have seen that issue at BlackIntel, causing commands to go to the wrong server. We still don't exactly understand how the hell that's possible, but it could happen. Wierdest bit was that the renrem ports where 10 ports away from each other normally. So say 5004 would be one renrem port, the other would be 5014 and the one after that 5024, yet sometimes commands got send to the wrong server.

The cause is that Renegade writes the port to the registry and reads it again later. If two servers start at the same time, they might overwrite the registry value before re-reading it, and thereby use the wrong port. [/offtopic]


BlackIntel admin/founder/coder
Please visit http://www.blackintel.org/
Previous Topic:Tiberian Technologies releases TT-scripts 4.0 open beta 3!
Next Topic:4.0 Problem during Install
Goto Forum:
  


Current Time: Sun Mar 24 21:22:39 MST 2019
.:: Contact :: Home ::.

Powered by: FUDforum 2.7.7RC2.
Copyright ©2001-2007 FUD Forum Bulletin Board Software